Драйверы NVIDIA и Linux (ядро 2.6.25)

У некоторых пользователей ОС Linux возникают проблемы при установке драйверов NVIDIA (71.86.04, 96.43.05, 169.12 и 171.06) в систему, использующую ядро 2.6.25.

Для того, чтобы решить эту проблему необходимо наложить некоторые "заплатки" (patches).

Этим и займемся!


Патчи могут использоваться с драйверами 32-bit/x86 и 64-bit/x86-64 архитектуры.

Для того, чтобы "пропатчить" драйвер релиза 169.12 для 64-битной системы, выполним следующие команды:

# sh /path_to/NVIDIA-Linux-x86_64-169.12-pkg2.run --apply-patch /path_to/NVIDIA_kernel-169.12-2286310.diff.txt # sh NVIDIA-Linux-x86_64-169.12-pkg2-custom.run

Для того, чтобы, к примеру, "пропатчить" драйвер релиза 71.86.04 для 32-битной системы, выполним следующие команды:

# sh /path_to/NVIDIA-Linux-x86_64-71.86.04-pkg0.run --apply-patch NVIDIA_kernel-71.86.04-2305230.diff.txt # sh NVIDIA-Lnux-x86_64-71.86.04-pkg0-custom.run

Необходимые патчи:

NVIDIA_kernel-71.86.04-2305230.diff.txt

NVIDIA_kernel-96.43.05-2290218.diff.txt

NVIDIA_kernel-169.12-2286310.diff.txt

P.S. Драйвер NVIDIA релиза 173.08 в "заплатках" не нуждается.